Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 11580 Ergebnisse ergeben.
Seite 570 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 567, 568, 569, 570, 571, 572, 573 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Index
Autor Nachricht
  Thema: Wörter zählen 
Phelan XLPH

Antworten: 15
Aufrufe: 633

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 14:09   Titel: AW: Wörter zählen Version: Office 2003
=SUMMENPRODUKT((BEREICH.VERSCHIEBEN($B$1;0;0;10000;1)="xx")*1;(BEREICH.VERSCHIEBEN($P$1;0;0;10000;1)="yy")*1)
  Thema: Große Probleme :} 
Phelan XLPH

Antworten: 15
Aufrufe: 591

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 13:58   Titel: AW: Große Probleme :} Version: Office 2003
...the same Way

Tabelle1  ABCDEFG1KostenstellMaterialartMatBezMaßeHilfsspalte1Hilfsspalte2 220076Alumin.Rahmen12020076Alumin.Rahmen1201 311200Alumin.Stütze3011200Alumin.Stütze302 411200Alumin.Stütze3011200Alumin.Stütze302 512345Alumin.Rahmen22412345Alumin.Rahmen2241 611200Alumin.Pfosten6011200Alumin.Pfosten602 711200Alumin.Pfosten5911200Alumin.Pfosten591 811200Alumin.Pfosten6011200Alumin.Pfosten602 9    =A2&B2&C2&D2=ZÄHLENWENN($E:$E;E2) 10       Formeln der TabelleZelleFormelE2=A2&B2&C2&D2F2=ZÄHLENWENN($E:$E;E2)E3=A3&B3&C3&D3F3=ZÄHLENWENN($E:$E;E3)E4=A4&B4&C4&D4F4=ZÄHLENWENN($E:$E;E4)E5=A5&B5&C5&D5F5=ZÄHLENWENN($E:$E;E5)E6=A6&B6&C6&D6F6=ZÄHLENWENN($E:$E;E6)E7=A7&B7&C7&D7F7=ZÄHLENWENN($E:$E;E7)E8=A8&B8&C8&D8F8=ZÄHLENWENN($E:$E;E8) [url=http://www.office-loesung.de/ftopic91422_0_0_asc.php]Excel Jeanie Html
  Thema: Änderungen verfolgen und kopieren 
Phelan XLPH

Antworten: 14
Aufrufe: 1189

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 13:45   Titel: AW: Änderungen verfolgen und kopieren Version: Office 2003
schau mal hier:
http://excelwelt.de/Werkzeugkiste/indexwerkz.html
  Thema: Änderungen verfolgen und kopieren 
Phelan XLPH

Antworten: 14
Aufrufe: 1189

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 13:34   Titel: AW: Änderungen verfolgen und kopieren Version: Office 2003
Abgleich in beide Richtungen?
  Thema: Application.Volatile - wozu? 
Phelan XLPH

Antworten: 4
Aufrufe: 8229

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 13:07   Titel: AW: Application.Volatile - wozu? Version: Office 2003
GENAU!

wird M.E. nicht oft gebraucht da meistens die Funktion ausgefürt werden soll wenn
ein Parameter geändert wird.
  Thema: Wörter zählen 
Phelan XLPH

Antworten: 15
Aufrufe: 633

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 12:39   Titel: AW: Wörter zählen Version: Office 2003
@eto

Dann besorg dir mal XL2007 mit 2^20 Zeilen (ünber 1Mio.)
da geht sowas.

Jetzt mal dir mal aus wenn die alle mit Formel belegt sind, während der Berechnungen kannste Urlaub machen Ha,Ha, Ha, Laughing Laughing Laughing

Bereich.Verschieben bringt nix, denn der FestBereich wird bei Löschung
generell kleiner.
  Thema: Wörter zählen 
Phelan XLPH

Antworten: 15
Aufrufe: 633

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 12:12   Titel: AW: Wörter zählen Version: Office 2003
Das ist klar wenn du die Formel mitlöschst

eine Möglichkeit wäre:
=SUMMENPRODUKT((B:B="xx")*1;(P:P="yy")*1)
Spalten ganz markieren, Nachteil:langsam
  Thema: Application.Volatile - wozu? 
Phelan XLPH

Antworten: 4
Aufrufe: 8229

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 11:56   Titel: AW: Application.Volatile - wozu? Version: Office 2003
Berechnungen reagieren auf neuenträge irgendwo aufm Blatt M.E. (nicht nur).
Das heisst dass bei Farbwechsel keine Berechnung stattfindet.

sobald ein Eintrag irgendwo inner Tabelle stattfindet wird test angworfen.
Ohne Volotile gibts keine aktualisierung
  Thema: Wörter zählen 
Phelan XLPH

Antworten: 15
Aufrufe: 633

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 11:46   Titel: AW: Wörter zählen Version: Office 2003
wat, wo ,bist du dir sicher? Laughing

Nochmal von vorne bitte.

Wenn ich etwas aus dem Datensatz lösche, werden die Werte aus der Berechnung aktualisiert
...ist das positiv oder negativ?
  Thema: Große Probleme :} 
Phelan XLPH

Antworten: 15
Aufrufe: 591

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 11:31   Titel: AW: Große Probleme :} Version: Office 2003
Dann lösen wir das mal ohne VBA:

1. Funktion ZÄHLEWENN in eine Hilfsspalte eintragen (siehe Bild)
2. Nach Hilfsspalte aufsteigend sortieren
3. Alle Zeillen Größer 1 in Hilfsspalte löschen
  Thema: Optimierung einer Suchanfrage 
Phelan XLPH

Antworten: 2
Aufrufe: 264

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 11:21   Titel: AW: Optimierung einer Suchanfrage Version: Office 2003
schau mal ob du das irgendwie übertragen kannst
  Thema: Große Datenbereiche abgleichen 
Phelan XLPH

Antworten: 7
Aufrufe: 261

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 10:31   Titel: AW: Große Datenbereiche abgleichen Version: Office 2007
hi Zedicus, teste mal:

Sub LoesenImGrossenStil()
Dim arr As Variant, arrVgl As Variant
Dim i As Long, t As Double, Exist As Boolean

With Tabelle1 'Anpassen
t = Timer

arr = .Range("D1:D" & .Cells(.Rows.Count, 4).End(xlUp).Row) 'anpassen
If Not IsArray(arr) Then Exit Sub

ReDim arrVgl(1 To UBound(arr), 1 To 1)
For i = 1 To UBound(arr)
Select Case Left$(arr(i, 1), 2)
Case "DE", "FR", "TR", "PL", "ES"
arrVgl(i, 1) = 1
Exist = True
End Select
Next

If Not Exist Then Exit Sub
Application.ScreenUpdating = False
.Range("A:A").Insert
.Range("A1").Resize(UBound(arrVgl)) = arrVgl
.UsedRange.Sort .Range("A1")
.Range(&quo ...
  Thema: Über RS232 Messwerte direkt in Excel einbringen 
Phelan XLPH

Antworten: 7
Aufrufe: 6770

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 09:08   Titel: AW: Über RS232 Messwerte direkt in Excel einbringen Version: Office 2003
hallo,
poste mal deinen Code
  Thema: Combobox Eingabe und Treffer 
Phelan XLPH

Antworten: 4
Aufrufe: 1175

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 09:02   Titel: AW: Combobox Eingabe und Treffer Version: Office 2003
hi, Überschrift wird mit eingelesen.

Private arrList As Variant

Private Sub ListBox1_Click()
Dim i As Long
Debug.Print 1
For i = 0 To ListBox1.ListCount - 1
If ListBox1.Selected(i) Then
MsgBox "Zeile: " & ListBox1.List(i, 0)
Exit For
End If
Next
End Sub

Private Sub TextBox1_Change()
Dim i As Long, k As Long, arrOut() As Variant
k = -1
For i = LBound(arrList) To UBound(arrList)
If LCase(arrList(i, 2)) Like TextBox1.Value & "*" Then
k = k + 1
ReDim Preserve arrOut(0 To 1, 0 To k)
arrOut(0, k) = i
arrOut(1, k) = arrList(i, 2)
End If
Next
If k < 0 Then
ListBox1.Clear
Else
ListBox1.Column = arrOut
End If
End Sub

Private Sub UserForm_Initialize()
...
  Thema: Spezialfilter 
Phelan XLPH

Antworten: 11
Aufrufe: 548

BeitragForum: Excel VBA (Makros)   Verfasst am: 13. Aug 2009, 02:06   Titel: AW: Spezialfilter Version: Office 2007
Very Happy
 
Seite 570 von 772 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 567, 568, 569, 570, 571, 572, 573 ... 766, 767, 768, 769, 770, 771, 772  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Access Tabellen