Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 155 Ergebnisse ergeben.
Seite 7 von 11 Gehe zu Seite Zur點k  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Index
Autor Nachricht
  Thema: Frage zu Wenn Text dann 
HKindler

Antworten: 3
Aufrufe: 76

BeitragForum: Excel Formeln   Verfasst am: 02. Dez 2013, 15:53   Titel: AW: Frage zu Wenn Text dann Version: Office 2007
Das geht doch auch mit G黮tigkeit - als Benutzerdefiniert:

燗B11񁺐33燴elleG黮tigkeitstypOperatorWert1Wert2A1Benutzerdefiniert=(B1="")*ISTZAHL(A1)燘1Benutzerdefiniert=(A1="")*ISTZAHL(B1)燗2Benutzerdefiniert=(B2="")*ISTZAHL(A2)燘2Benutzerdefiniert=(A2="")*ISTZAHL(B2)燗3Benutzerdefiniert=(B3="")*ISTZAHL(A3)燘3Benutzerdefiniert=(A3="")*ISTZAHL(B3)燚iese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. 〨erd alias Bamberg
  Thema: Excel 2010 kann keine 黚ereinstimmende Daten finden 
HKindler

Antworten: 12
Aufrufe: 322

BeitragForum: Excel Formate   Verfasst am: 02. Dez 2013, 15:06   Titel: AW: Excel 2010 kann keine 黚ereinstimmende Daten finden Version: Office 2010
Vorsicht beim Suchen und Ersetzen: Wenn beim Aufruf der Funktion mehrere Zellen markiert sind, dann durchsucht Excel nur die markierten Zellen. Vielleicht ist das ja auch hier das Problem.
  Thema: Bei Excel mit Stunden und Minuten rechnen 
HKindler

Antworten: 7
Aufrufe: 259

BeitragForum: Excel Formate   Verfasst am: 02. Dez 2013, 15:00   Titel: AW: Bei Excel mit Stunden und Minuten rechnen Version: Office 2010
Lies dich mal darin ein, wei Excel Daten (Plural von Datum) und Uhrzeiten behandelt. Zu finden z.B. hier: http://www.pcwelt.de/tipps/Tipps-fuer-ein-besseres-Excel-Rechnen-mit-Datum-und-Zeit-6053533.html
Und du wirst feststellen, dass das alles ganz einfach ist!

Ganz kurz: F黵 Excel sind Tage/Uhrzeiten nichts anderes als Kommazahlen. Vor dem Komma stehen die Tage, nach dem Komma die Uhrzeiten. 24 Stunden geben genau 1,0. Die Darstellung als Stunden oder Datum geschieht dann ganz einfach durch entsprechende Formatierung der Zellen.
  Thema: Datums umwandeln 
HKindler

Antworten: 5
Aufrufe: 108

BeitragForum: Excel Formeln   Verfasst am: 28. Nov 2013, 13:09   Titel: AW: Datums umwandeln Version: Office XP (2002)
Oder auch einfach mit

EDATUM(HEUTE();-1)

und entsprechend formatieren ("MM/JJJJ" als benutzerdefinirtes Format der Zelle)
  Thema: ausgez鋒lte anzahl darstellen 
HKindler

Antworten: 2
Aufrufe: 77

BeitragForum: Excel Hilfe   Verfasst am: 26. Nov 2013, 11:33   Titel: AW: ausgez鋒lte anzahl darstellen Version: Office 2010
Mit einer reinen Excel-Formel etwa so (in A1):

=A2&A3&A4&A5

Nachteil: Man muss jede Zelle einzeln angeben.

Oder mit einer UDF in VBA:
Folgenden Code in ein allgemeines Modul, z.B. Modul1.

Function Spaltenkopf(Bereich As Range) As String
Dim Zelle As Range
For Each Zelle In Bereich
Spaltenkopf = Spaltenkopf & Zelle
Next Zelle
End Function

Der Aufruf erfolgt dann in A1 mit =SPALTENKOPF(A2:A5)
  Thema: Mehr als 7 Wenn Funktionen 
HKindler

Antworten: 19
Aufrufe: 13232

BeitragForum: Excel Formeln   Verfasst am: 25. Nov 2013, 16:29   Titel: AW: Mehr als 7 Wenn Funktionen Version: Office 2k (2000)
Wie w鋜e es mit:

=SUMME(INDIREKT("ZS2:ZS"&MONAT(HEUTE())+1;FALSCH))

PS:
Das mit der 2. Seite habe ich auch 黚ersehen Embarassed
Aber die Formel lasse ich jetzt trotzdem stehen!
  Thema: die letzten 50 bei summewenns 
HKindler

Antworten: 2
Aufrufe: 72

BeitragForum: Excel Formeln   Verfasst am: 25. Nov 2013, 15:51   Titel: AW: die letzten 50 bei summewenns Version: Office 2010
Ohne Hilfszelle wird das wohl kaum was werden. Mir f鋖lt zumindest nichts ein.

Also gesucht wird die Summe von C der 50 letzten Eintr鋑e bei denen gilt A=1, B=2.
Eine Hilfszelle in D1 gibt dir die Zeilennummer des 50-letzten Werts (Achtung! MAtrixformel die "{}" nicht mit eingeben, daf黵 beim Abschluss der Formel statt "ENTER" "STRG-SHIFT-ENTER" dr點ken):
{=KGR諷STE(WENN(A1:A200=1;WENN(B1:B200=2;ZEILE(1:200)));50)}
In D2 bekommst du nun die Summe mit
=SUMMEWENNS(INDIREKT("C"&D1&":C200");INDIREKT("A"&D1&":A200");1;INDIREKT("B"&D1&":B200");2)
  Thema: Automatische Zellensperrung funktioniert nicht 
HKindler

Antworten: 2
Aufrufe: 72

BeitragForum: Excel VBA (Makros)   Verfasst am: 25. Nov 2013, 14:40   Titel: AW: Automatische Zellensperrung funktioniert nicht Version: Office 2010
Hi Juzebeau,

zu deinem eihgentlichen Problem kann ich nichts sagen, da ich noch nie mit Sendkeys gearbeitet habe. Habe ich ehrlich gesagt noch nie gebraucht und scheue mich 黚er Tastatur-Befehle zu gehen, da einem der Benutzer da ja dazwischen funken k鰊nte. Meist gibt es bessere L鰏ungen.

Aber weshalb ich hier schreibe: Wieso machst du den Eintrag der Uhrzeit so umst鋘dlich? W鋜e es nicht viel einfach das so zu machen:

' aktuelle Uhrzeit stempeln
If InRange(ActiveCell, Range("W8:Y38")) Then
' code to handle that the active cell is within the right range

' Stempelung absetzten
ActiveCell=Format(Now,"hh:mm:ss")
Application.SendKeys "{F2}{TAB}"

Else

Mir ist jetzt auch noch nicht wirklich klar, was die ganze Sendkeys-Geschichte bewirken soll. Meines erachtens nach dient sie nur dazu eine neue Zelle aus zu w鋒len. Das kannst du dann auch so mac ...
  Thema: 4-stellige Postleitzahlen um eine weitere Zahl erg鋘zen 
HKindler

Antworten: 5
Aufrufe: 229

BeitragForum: Excel Hilfe   Verfasst am: 25. Nov 2013, 13:53   Titel: AW: 4-stellige Postleitzahlen um eine weitere Zahl erg鋘zen Version: Office 2007
Oder einfach weiter mit normalen Zahlen arebiten und als Zellformat "00000" einstellen...
  Thema: SVERWEIS bzw. WENN auf mehrere Kriterien 
HKindler

Antworten: 3
Aufrufe: 58

BeitragForum: Excel Formeln   Verfasst am: 20. Nov 2013, 14:53   Titel: AW: SVERWEIS bzw. WENN auf mehrere Kriterien Version: Office 2007
Ganz einfach:


=WENN(UND(Tabelle2!I:I=B6;Tabelle2!E:E="F";Tabelle2!B:B=F6); Tabelle2!C:C);"")
  Thema: Formelvereinfachung gesucht 
HKindler

Antworten: 11
Aufrufe: 120

BeitragForum: Excel Formeln   Verfasst am: 11. Nov 2013, 18:28   Titel: AW: Formelvereinfachung gesucht Version: OpenOffice/StarOffice
Sorry, war gerade nicht eingeloggt. Embarassed
Das mit der VBA-Routine, was war ich.
  Thema: *T*summe wenn - eine bedingung mehrere spalten abfragen 
HKindler

Antworten: 4
Aufrufe: 105

BeitragForum: Excel Hilfe   Verfasst am: 28. Okt 2013, 14:51   Titel: AW: *T*summe wenn - eine bedingung mehrere spalten abfragen Version: Office 2010
Wenn wirklich in der einen Spalte (z.B. "B") immer nur Text und in der anderen immer nur Zahlen stehen, dann kann man die Formel deutlich vereinfachen:

=SUMMEWENN($B$4:$AV$1000;G1;$C$4:$AW$1000)

Allerdings wird die Rechenzeit sich etwa verdopplen. Sollte das eine Rolle spielen, dann w黵de ich das so machen:

ABCDE1Suchenabc300 3002gesamt600 3 07:00Output08:00Output4DP8abc300klm2005DP9cde400hij7006DP11efg600abc3007DP12hij700opq1008DP13klm200cde4009DP15opq100hij700ZelleFormelC1=SUMMEWENN(B4:B1000;$B$1;C4:C1000)E1=SUMMEWENN(D4:D1000;$B$1;E4:E1000)B2=SUMME(1:1)Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. 〨erd alias Bamberg

Dann einfach B1:C1 markieren und so weit nach rechts ziehen wie n鰐ig.
Die Zeilen in der SUMMEWENN-Formel nat黵lich vorher entsprechend anpassen.
  Thema: Abh鋘gige Listenauswahl - leicht zu erfassen, aber schwierig 
HKindler

Antworten: 2
Aufrufe: 71

BeitragForum: Excel VBA (Makros)   Verfasst am: 25. Okt 2013, 14:25   Titel: AW: Abh鋘gige Listenauswahl - leicht zu erfassen, aber schwi Version: Office 2013
Hilft dir das weiter?

http://www.excelformeln.de/tips.html?welcher=84
  Thema: Daten G黮tigkeit, Dropdown - pseudoleere Zellen?! 
HKindler

Antworten: 3
Aufrufe: 145

BeitragForum: Excel Hilfe   Verfasst am: 25. Okt 2013, 13:25   Titel: AW: Daten G黮tigkeit, Dropdown - pseudoleere Zellen?! Version: Office XP (2002)
Warum nimmst du nicht direkt die Liste von Blatt2?

Bei neuen Excel-Versionen >2007 kann man das direkt machen.

Unter OfficeXP geht das, indem man der Liste auf dem anderen Blatt einen Namen gibt.
Dazu in deinem Fall auf Blatt2 die Zellen B1:B3 markieren. Dann in dem Feld, in dem die Adresse der aktuellen Zelle angezeigt wird, den gew黱schten Namen eingeben. In deinem Fall m黶ste in dem Feld B1 stehen. Dort jetzt z.B. MeineListe eingeben.
Jetzt bei der G黮tigkeit "Liste" ausw鋒len und =MeineListe eingeben.
  Thema: WorksheetFunction.Large und gro遝 Arrays 
HKindler

Antworten: 6
Aufrufe: 92

BeitragForum: Excel VBA (Makros)   Verfasst am: 22. Okt 2013, 18:52   Titel: AW: WorksheetFunction.Large und gro遝 Arrays Version: Office 2010
So funktioniert es jetzt (der Anfang ist gleich wie im ersten Beitrag):

LetzterEintrag = Large(vErg, Anzahl)
End Function
Function Large(DasFeld() As Variant, ByVal k As Double) As Double
Dim iMin As Double
Dim iMax As Double
iMin = LBound(DasFeld)
iMax = UBound(DasFeld)
If iMax - iMin + 1 < k Then Large = 0: Exit Function
QuickSort DasFeld, iMin, iMax
Large = DasFeld(iMax - k + 1)
End Function
Sub QuickSort(DasFeld() As Variant, StartUnten As Double, EndeOben As Double)
'QuickSort Standard
Dim iUnten As Double, iOben As Double
Dim Mitte As Variant, y0 As Variant
iUnten = StartUnten
iOben = EndeOben
Mitte = DasFeld((StartUnten + EndeOben) / 2)
While (iUnten <= iOben)
While (DasFeld(iUnten) < Mitte And iUnten < EndeOben)
iUnten = iUnten + 1
Wend
While (Mitte < DasFeld(iOben) And iOben > StartUnten)
...
 
Seite 7 von 11 Gehe zu Seite Zur點k  1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel Tricks