Datumsabfrage beim öffnen der Tabelle

Antwort erstellen

Smilies
:D :) :( :o :shock: :? 8-) :lol: :x :P :razz: :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: :badgrin: :doubt:
BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind eingeschaltet
Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: Datumsabfrage beim öffnen der Tabelle

Re: Datumsabfrage beim öffnen der Tabelle

Beitrag von RPP63 » 01. Mai 2020, 16:01

Ich glaube, es handelt sich hier um ein XY-Problem.
Vielleicht schilderst Du Dein Vorhaben mal genauer, gern in Verbindung mit einer Datei.

Um ein Dropdown zu füllen, reicht es ja durchaus die Datumsspalte temporär zu filtern und die sichtbaren Wörter aus SpalteA zu übergeben.
Grob so:
Code: Alles auswählen
ComboBox1.List = Range("A2:A87").SpecialCells(xlCellTypeVisible).Value

Re: Datumsabfrage beim öffnen der Tabelle

Beitrag von Ulli 01 » 01. Mai 2020, 15:52

Hallo Ralf,

danke erst mal, aber ich brauche das als VBA, da ich sich eine Combobox aus einer Userform darüber speist. D.h. die Daten in Spalte C werden auch teils wieder gelöscht und somit wäre auch die Formel wieder gelöscht.

Hätte ich so mit formulieren sollen.

Sorry

Re: Datumsabfrage beim öffnen der Tabelle

Beitrag von RPP63 » 01. Mai 2020, 15:38

Moin!
Warum VBA?
C2: =WENN((B2-HEUTE())<1;A2;"")

Gruß Ralf

Datumsabfrage beim öffnen der Tabelle

Beitrag von Ulli 01 » 01. Mai 2020, 14:50

Hallo Forum,

ich arbeite mit einer Tabelle, wo in Spalte B ein Datum eingetragen wird und in Spalte A ein Wort steht. Nun möchte ich, dass beim öffnen der Datei per VBA geprüft wird, ob dieses Datum erreicht oder überschritten worden ist. Wenn das so ist, soll automatisch das Wort aus Spalte A in Spalte C der Zeile kopiert werden.

Kann mir Jemand helfen?

Nach oben

cron