Kürzere/ optimiertere Formel möglich?

Antwort erstellen

Smilies
:D :) :( :o :shock: :? 8-) :lol: :x :P :razz: :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: :badgrin: :doubt:
BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind eingeschaltet
Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: Kürzere/ optimiertere Formel möglich?

Re: Kürzere/ optimiertere Formel möglich?

Beitrag von slowboarder » 13. Sep 2021, 12:22

ok, wenn das nicht vorkommt, kannst du meine Formel verwenden.
falls es doch mal passiert, bekommst du einen entsprechenden Hinweis.
Gruß Daniel

Re: Kürzere/ optimiertere Formel möglich?

Beitrag von sven8219 » 13. Sep 2021, 12:14

Hallo Daniel,

es gibt IMMER nur eines der drei Optionen:
ok, nok oder der Name Name taucht nicht auf, dann leer.

Re: Kürzere/ optimiertere Formel möglich?

Beitrag von slowboarder » 13. Sep 2021, 12:06

Hi
als Formel etwas kürzer, aber obs wirklich weniger Rechenaufwand bedeutet, weiß ich nicht:

=WAHL(1+SUMMENPRODUKT((ZÄHLENWENNS(Testergebnisse!$D:$D;LINKS($B$4;FINDEN(",";$B$4)-1);Testergebnisse!$A:$A;E3;Testergebnisse!$M:$M;{"ok";"nok"})>0)*{1;2});"";1;0;"beides")

ist denn die Kombination aus Datum und Name eindeutig?
oder kann das mehrfach vorkommen, so das "ok" und "nok" gleichzeitig vorkommen können?

Gruß Daniel

Re: Kürzere/ optimiertere Formel möglich?

Beitrag von Der Steuerfuzzi » 13. Sep 2021, 10:54

Hallo,

eine Beispieldatei wäre hilfreich.

Kürzere/ optimiertere Formel möglich?

Beitrag von sven8219 » 13. Sep 2021, 10:13

Hallo zusammen,

ich habe eine Auswertung in der in Spalte D der Name mit B4 übereinstimmen soll zudem muss in Spalte A das Datum mit E3 stimmen und dann kommt der Knackpunkt.
Es muss noch Spalte M geprüft werden ob der Text "ok" oder "nok" beinhaltet und entsprechend eine 1 oder eine 0 ausgeben. Ist gar kein Wert vorhanden soll es leer bleiben.
Ich habe das über eine große WENN Formel gelöst, suche aber etwas kürzeres, da es eine große Datenbank ist. Vielleicht hab ihr ja eine gute Alternative :)

Code: Alles auswählen
=WENN(ZÄHLENWENNS(Testergebnisse!$D:$D;LINKS($B$4;FINDEN(",";$B$4)-1);Testergebnisse!$A:$A;E3;Testergebnisse!$M:$M;"ok");1;WENN(ZÄHLENWENNS(Testergebnisse!$D:$D;LINKS($B$4;FINDEN(",";$B$4)-1);Testergebnisse!$A:$A;E3;Testergebnisse!$M:$M;"nok");0;""))


Danke euch


Gruß
Sven

Nach oben