Zählenwenn

Moderator: ModerationP

Zählenwenn

Beitragvon Martha1 » 23. Okt 2021, 15:14

Hallo,

ich suche nach einer Lösung für ein Zählenwenn Funktion.

Es soll die Nummer nur einmal gezählt werden, die Nummern sind aber mehrfach vorhanden.

Ich habe eine Bsp. Datei angehängt.

Vielen Dank vorab.

Martha
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Martha1
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 157
Registriert: 07. Mai 2017, 15:58

Re: Zählenwenn

Beitragvon 1Matthias » 23. Okt 2021, 15:21

Moin!
Füge in F3 mal die formel ein und ziehe sie runter;
Code: Alles auswählen
=WENN(ZÄHLENWENN($C$2:C2;C3)>0;0;1)

Die Idee ist, zu prüfen, ob in dem Bereich davor schon einmal die Zahl vorkam. Wenn ja, wird 0 eingetragen, sonst eine 1. KLappt so aber nur, wenn es eine Überschriftenzeile gibt. In der der startet der zu durchsuchende Bereich.
VG

PS: Ohne den Start in der Überschriftenzeile dann so
=WENN(ZÄHLENWENN($C$3:C3;C3)>1;0;1)
Zuletzt geändert von 1Matthias am 23. Okt 2021, 15:38, insgesamt 1-mal geändert.
1Matthias
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 975
Registriert: 15. Aug 2017, 18:36

Re: Zählenwenn

Beitragvon < Peter > » 23. Okt 2021, 15:24

Hallo,

ich bin mir nicht sicher ob ich dein Anliegen richtig verstanden habe aber evtl. hilft auch diese Formel:

=SUMME((HÄUFIGKEIT(C$3:C$11;C$3:C$11)<>0)*1)
Gruß
Peter
Benutzeravatar
< Peter >
Moderator
 
Beiträge: 66674
Registriert: 04. Sep 2004, 10:19
Wohnort: Das schönste Land in Deutschlands Gaun

Re: Zählenwenn

Beitragvon shift-del » 23. Okt 2021, 15:25

Moin

Code: Alles auswählen
=ANZAHL(EINDEUTIG(C3:C11))
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21721
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände

Re: Zählenwenn

Beitragvon Martha1 » 23. Okt 2021, 17:30

Hallo,

danke an Peter und Mathias.

Das ist genau das was ich gesucht habe.

Die Formel von Shift-DEl klappt bei mir leider nicht.

Danke an alle für die schnelle Hilfe,

Martha
Martha1
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 157
Registriert: 07. Mai 2017, 15:58

Re: Zählenwenn

Beitragvon shift-del » 23. Okt 2021, 17:34

Martha1 hat geschrieben:Die Formel von Shift-DEl klappt bei mir leider nicht.

Dann hast du etwas falsch gemacht.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21721
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände

Re: Zählenwenn

Beitragvon Flotter Feger » 23. Okt 2021, 18:06

... was ist den falsch daran, wenn man kein 365/2021 hat ?

Sie hat dann halt kein EINDEUTIG ...
VG Sabina

Wer auch weiter Hilfe erwartet, sollte sich nicht zu schade sein, ein kurzes Feedback zu geben.
Bei mir läuft Win 7 32-Bit - Office 2016 Pro Plus 32-Bit, Office 2019 Pro Plus 32-Bit und Office 2021 Pro Plus 32-Bit
Benutzeravatar
Flotter Feger
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 3333
Registriert: 24. Okt 2016, 16:40

Re: Zählenwenn

Beitragvon shift-del » 23. Okt 2021, 18:54

Flotter Feger hat geschrieben:... was ist den falsch daran, wenn man kein 365/2021 hat ?

Die Formel würde klappen wenn man Office 365 hat.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21721
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: cptSmok, GMG-CC, Klaus-Dieter und 14 Gäste