Formel

Moderator: ModerationP

Formel

Beitragvon Smartis » 24. Jul 2020, 14:38

ein Hallo an die Experten

wie zu erwarten , Ich habe ein Problem und komme nicht weiter :(

A1: =WENN(ISTLEER($G$45);"";E36+F36)
B1: =WENN(ISTLEER($G$45);"Datum";C38)
C1: =WENN(ISTLEER($G$45);"";(D38-E36)/(365)*(Z36)) und hier ist der Teufel im Detail, es kommen krumme Zahlen raus, bei xxx,5....9 ist ja
alles gut, aber von xxx,1...4 ist das Problem, ich hab schon mit "Aufrunden(C1);0) versucht, aber Excel meckert.

danke schon mal im voraus
Smartis
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5
Registriert: 25. Aug 2018, 15:56

Re: Formel

Beitragvon Pearli123 » 24. Jul 2020, 18:46

Es würden wahrscheinlich mehr Leute helfen können/wollen, wenn man auch weiß, was hinter den Zellangaben steckt, meinst du nicht auch? :roll:
Hilfreich wäre auch, was denn rauskommen soll bzw. was du erwartest.

Apropro: Wenn du etwas durch 365 teilst, kommen meistens Kommawerte bei raus.
Pearli123
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 1433
Registriert: 20. Feb 2017, 13:38

Re: Formel

Beitragvon shift-del » 24. Jul 2020, 19:06

Smartis hat geschrieben:C1: =WENN(ISTLEER($G$45);"";(D38-E36)/(365)*(Z36)) und hier ist der Teufel im Detail, es kommen krumme Zahlen raus, bei xxx,5....9 ist ja

Bei mir kommt 0 raus.
Problem ist gelöst.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21689
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände

Re: Formel

Beitragvon Smartis » 24. Jul 2020, 19:48

Hallo

o.k. dann noch mal auf ein neues :)

in Zelle c38: 818 und d38: (835) ohne jeglicher Formel weil ich da Veränderung vornehmen muss.
Zelle G36 und H36 enthalten das Start und End Datum aus G45 / G46 ist eins enthalten soll in
F36: =WENN(ISTLEER($G$45);"";(D38-E36)/(365)*(Z36)) was auch klappt. Dieser Wert wird dann
in D36 Addiert Formel dazu in D36 ist =WENN(ISTLEER($G$45);"";E36+F36)
so weit so gut, nun Steht aber nur 1 und nicht 2, da ich dann mit diesen Wert die Tabelle weiter
führe. Deshalb sollte dann der wert in F36 (1,4) noch Aufgerundet werden auf 2.
Ich hoffe du kannst damit mehr Anfangen.
und danke schon mal
Smartis
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5
Registriert: 25. Aug 2018, 15:56

Re: Formel

Beitragvon Smartis » 24. Jul 2020, 20:41

Noch mal ein Hallo

man kann es auch ganz kurz beschreiben
in F4 folgende Formel "=WENN(ISTLEER($G$45);"";(D30-E28)/(365)*(Z28))"
wenn ein Ergebnis von 0,1 bis 0,9 ;1,1 bis 1,9 ; 2,1 bis 2,9 …..
die Funktion "Aufrunden" auf nächste Zahl 1; 2; 3 …
Smartis
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5
Registriert: 25. Aug 2018, 15:56

Re: Formel

Beitragvon shift-del » 24. Jul 2020, 21:32

Ich vermute mal nach fünf weiteren Beiträgen von dir ändern sich die Zellbezüge/Formeln so weit dass sie nicht mehr mit dem ersten Beitrag übereinstimmen.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21689
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände

Re: Formel

Beitragvon Pearli123 » 24. Jul 2020, 22:55

Pack doch einfach um deine Formel =AUFRUNDEN(DEINE_FORMEL;0) drum herum und fertig...
Pearli123
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 1433
Registriert: 20. Feb 2017, 13:38


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: losgehts und 20 Gäste