SVERWEIS in Wertgruppen

Moderator: ModerationP

SVERWEIS in Wertgruppen

Beitragvon Tolados » 14. Sep 2021, 11:13

Hallo zusammen,

ich stehe gerade etwas auf dem Schlauch. Ich habe eine Liste
Wertgruppe Preis
bis 25.000 € 300,00 €
bis 50.000 € 400,00 €
bis 75.000 € 500,00 €
bis 100.000 € 650,00 €

nun möchte ich in einer Formel, wenn ich z.B. 25.500 € eingebe, dass dann als Ergebnis 400 € und nicht 300 € zurückgegeben wird.
Geht das mit Bordmitteln oder brauche ich dafür VBA?

Vielen Dank schonmal vorab!
Tolados
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 119
Registriert: 15. Mär 2017, 08:29

Re: SVERWEIS in Wertgruppen

Beitragvon Boris71 » 14. Sep 2021, 11:22

Hi,

änder die Wertgruppen in ab

Also A1:B5:

Code: Alles auswählen
Ab      Preis
0       300
25001   400
50001   500
75001   650


Dazu Suchwert in E2:

=SVERWEIS(E2;A2:B5;2)

VG, Boris
Boris71
 

Re: SVERWEIS in Wertgruppen

Beitragvon slowboarder » 14. Sep 2021, 11:23

Hi

Das geht problemlos mit dem SVerweis mit 4. Parameter = Wahr.
Allerdings müssen in der ersten Spalte nicht die BIS-Werte stehen, sondern die AB-Werte, also immer der kleinste Wert, ab dem diese Zeile als Ergebnis verwendet werden soll:

00.001 | 300
25.001 | 400
50.001 | 500

Usw.
slowboarder
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28446
Registriert: 18. Apr 2009, 13:33

Re: SVERWEIS in Wertgruppen

Beitragvon Tolados » 14. Sep 2021, 11:56

ohje, was bin ich doch für ein Schaf.... da hätte ich auch mal selbst drauf kommen können.
Vielen Dank Euch beiden!
Tolados
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 119
Registriert: 15. Mär 2017, 08:29


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 18 Gäste