Diagramm reagiert nicht auf Filter in Abfrage

Moderator: ModerationP

Diagramm reagiert nicht auf Filter in Abfrage

Beitragvon MononokeHimeNEU » 02. Sep 2021, 12:23

Hallo,

ich habe in einem Formular ein Diagramm und eine Tabelle eingebunden. Für beides ist die gleiche Abfrage die Grundlage, um Daten anzuzeigen.
Jetzt möchte ich, dass man die Daten über die Auswahl in einem Kombinationsfeld auf dem Hauptformular filtern kann.
Dafür habe ich in die Abfrage den folgenden Bezug zum Kombinationsfeld hinterlegt:

wie [Forms]![Name_Hauptformular]![Name_Kombinationsfeld]


Für die eingebundene Tabelle funktioniert der Filter bei Auswahl im Kombinationsfeld auch prima. Nur beim Diagramm erhalte ich ständig die Fehlermeldung:

Das Microsoft Access-Datenbankmodul erkennt ' [Forms]![Name_Hauptformular]![Name_Kombinationsfeld]' nicht als gültigen Feldnamen oder Ausdruck.


Ich habe eine "Wie" bzw. "like" Filterung hinterlegt, weil ich im Kombinationsfeld den Standardwert "*" für alle Eintragungen hinterlegt habe...

Kann man einen solchen Filter bei Diagrammen nicht verwenden? Weiß jemand was ich hier anders machen müsste?

schon mal vielen Dank im voraus!
MononokeHimeNEU
 

Re: Diagramm reagiert nicht auf Filter in Abfrage

Beitragvon MononokeHimeNEU » 02. Sep 2021, 12:30

Kleine Korrektur meines Filters:

wie [Forms]![Name_Hauptformular].[Name_Kombinationsfeld]


Vor dem Verweis auf das Kombinationsfeld habe ich natürlich einen Punkt stehen...
MononokeHimeNEU
 


Zurück zu Access Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste